Para entrar em contato comigo, seja para falar sobre o blog, fazer comentários, tirar dúvidas você pode enviar um e-mail para alexanmtz@gmail.com

12 Replies to “Contato”

  1. Opa, gostaria de uma ajuda, se possível.

    Eu tenho formulários em uma página, faço o validate, até com o remote, e funciona normal, o problema é mandar os dados, não posso sair da página, minha ideia é mandar os dados via Ajax, e o ajax retorna via json o necessário, tipo, se concluiu com sucesso, o que resultou a busca….
    eu sempre voltaria um node status: 0 ou 1, e a mensagem de erro ou de conclusão. Enfim, o único problema é o submitHandler que não estou conseguindo fazer, se eu mando via AjaxSubmit() ele não me retorna os dados, via json e se mando via ajax ele redireciona pra página…

    1. @Marcelo: Marcelo, você está utilizando o return false para prevenir a submissão do formulário? Ele está direcionando provavelmente por causa disto ou algum erro de script que quebra seu script.

  2. Alexandre há muito tempo procurava um template simples , mas prático e eficiente , sem estruturas desnecessárias, que tivesse opção de prover um espaço entre as as colunas e o header. Adorei o seu template. Talvez eu o use em meu próximo site. Parabéns pelo conteúdo também.
    Abraço

  3. Boa Noite,

    Alexandre, gostaria de ver se podes esclarecer algumas dúvidas referente ao Bootstrap 3.0.2.

    Alterou a chamada dos arquivos do Bootstrap?
    Alterou o método de chamar os objetos?
    O que é o arquivo bootstrap-theme?

    Obrigado.

    1. @Gilson: Houve mudanças significativas do 2 para o 3. A chamada não alterou e nem a forma de javascript de chamar objetos. As mudanças principais estão nas classes CSS. Consulte a documentação para saber melhor das mudanças. Abraços e boa sorte.

  4. Opa,

    Alexandre agora venho com um problema.

    Estou com um problema no modal.

    Criei um efeito de com o z-index no rodapé e conteúdo do meu projeto e quando clico para abrir o modal ele abre abaixo da sombra.

    Teria alguma sugestão?

    Peço desculpa pelo tamanho do post.

    Seguem os códigos:
    Core.css
    ===============================================================================

    .corpo {
    min-height: 100%;
    position: relative;
    z-index: inherit;
    -webkit-box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    -moz-box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    }
    .conteudo {
    overflow: hidden;
    padding-bottom: 50px;
    position: relative;
    z-index: 200;
    margin-left: 30px;
    margin-top: -20px;
    padding-top: 20px;
    background-color: #FFFFFF;
    -webkit-box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    -moz-box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    box-shadow: inset 0 1px 8px rgba(0, 0, 0, 0.100);
    }
    .conteudo-interno {
    margin-left: 15px;
    }
    .rodape {
    color: #FFFFFF;
    background-color: #468847;
    padding-top: 5px;
    padding-bottom: 10px;
    position: absolute;
    bottom: 0;
    }
    .rodape-full {
    margin: 0 auto;
    position: fixed;
    z-index: inherit;
    left: 0;
    width: 100%;
    }

    ===============================================================================

    Bootstrap.css
    ===============================================================================

    .modal-backdrop {
    position: fixed;
    top: 0;
    right: 0;
    bottom: 0;
    left: 0;
    z-index: 1025;
    background-color: #000000;
    }

    .modal-backdrop.fade {
    opacity: 0;
    }

    .modal-backdrop,
    .modal-backdrop.fade.in {
    opacity: 0.8;
    filter: alpha(opacity=80);
    }

    .modal {
    position: fixed;
    top: 10%;
    left: 50%;
    z-index: 1050;
    width: 560px;
    margin-left: -280px;
    background-color: #ffffff;
    border: 1px solid #999;
    border: 1px solid rgba(0, 0, 0, 0.3);
    *border: 1px solid #999;
    -webkit-border-radius: 6px;
    -moz-border-radius: 6px;
    border-radius: 6px;
    outline: none;
    -webkit-box-shadow: 0 3px 7px rgba(0, 0, 0, 0.3);
    -moz-box-shadow: 0 3px 7px rgba(0, 0, 0, 0.3);
    box-shadow: 0 3px 7px rgba(0, 0, 0, 0.3);
    -webkit-background-clip: padding-box;
    -moz-background-clip: padding-box;
    background-clip: padding-box;
    }

    .modal.fade {
    top: -25%;
    -webkit-transition: opacity 0.3s linear, top 0.3s ease-out;
    -moz-transition: opacity 0.3s linear, top 0.3s ease-out;
    -o-transition: opacity 0.3s linear, top 0.3s ease-out;
    transition: opacity 0.3s linear, top 0.3s ease-out;
    }

    .modal.fade.in {
    top: 10%;
    }

    .modal-header {
    padding: 9px 15px;
    border-bottom: 1px solid #eee;
    }

    .modal-header .close {
    margin-top: 2px;
    }

    .modal-header h3 {
    margin: 0;
    line-height: 30px;
    }

    .modal-body {
    position: relative;
    max-height: 400px;
    padding: 15px;
    overflow-y: auto;
    }

    .modal-form {
    margin-bottom: 0;
    }

    .modal-footer {
    padding: 14px 15px 15px;
    margin-bottom: 0;
    text-align: right;
    background-color: #f5f5f5;
    border-top: 1px solid #ddd;
    -webkit-border-radius: 0 0 6px 6px;
    -moz-border-radius: 0 0 6px 6px;
    border-radius: 0 0 6px 6px;
    *zoom: 1;
    -webkit-box-shadow: inset 0 1px 0 #ffffff;
    -moz-box-shadow: inset 0 1px 0 #ffffff;
    box-shadow: inset 0 1px 0 #ffffff;
    }

    .modal-footer:before,
    .modal-footer:after {
    display: table;
    line-height: 0;
    content: "";
    }

    .modal-footer:after {
    clear: both;
    }

    .modal-footer .btn + .btn {
    margin-bottom: 0;
    margin-left: 5px;
    }

    .modal-footer .btn-group .btn + .btn {
    margin-left: -1px;
    }

    .modal-footer .btn-block + .btn-block {
    margin-left: 0;
    }

    ===============================================================================

  5. Alexandre,
    Instalei o plugin WP-Agenda num WP rodando no meu note. Só que toda hora aparece a mensagem: “blockUI requires jQuery v1.2.3 or later! You are using v1.10.2“. Como você vê, estou usando uma versão mais recente, e, mesmo assim, esse alerta não para de piscar, motivo pelo qual tive de desinstalar o plugin que estava funcionando perfeitamente.
    Att.,

    1. @Gills: Este problema anda acontecendo repetinamente. Irei retirar a dependência do BlockUI na próxima versão para que este problema não ocorra mais. Mesmo com o jQuery mais atualizado, por algum motivo ele continua aparecendo. Obrigado e avisarei assim que lançar uma próxima versão.
      Abraços,

  6. Boa noite,
    eu possuo um site de upload, porém eu não entendo nada de php, jquery e etc.. estou com um problema que impede de eu upar os arquivos.

    O site funciona da seguinte forma

    cadastro uma coleção, seto as informações e coloco uma imagem de capa, porem a aparece um erro de função php.

    Porém a coleção é upada normalmente no site, mas sem a capa.

    Os arquivos que vão ser inseridos dentro dessa coleção ficam em outra aba, entro la, localizo a coleção e pego os arquivos do meu PC e deixo na Queue, porém o botão de enviar sumiu.

    Se você puder me ajudar, eu seria muito grato. O meu site ja teve alguma relevância e acabei aposentando ele por falta de tempo. Mas agora estou voltando, no facebook apesar de ter perdido o movimento com esse tempo parado ainda tenho mais de 2k, sei que não é muito mas ficarei feliz em te divulgar, você merecia muito mais pelo conteúdo apresentado, eu leio apesar de não entender muito, pois você torna bem fácil.

    abraços

Deixe um comentário para Gilson Luiz Cancelar resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *